Unexpected issues with web-apps
Incident Report for Trimble Transport & Logistics
Resolved
This incident has been resolved.
Posted May 16, 2018 - 11:19 CEST
Investigating
We are currently investigating issues with some of our web-applications.
Posted May 16, 2018 - 11:07 CEST
This incident affected: Fleetworks and Fleetcockpit.