Unexpected issues with web-applications
Incident Report for Trimble Transport & Logistics
Resolved
This incident has been resolved.
Posted Jun 07, 2018 - 14:04 CEST
Investigating
We are investigating complaints about decreased performance of web-apps.
Posted Jun 07, 2018 - 13:57 CEST
This incident affected: Fleetworks and Fleetcockpit.