Degraded performance for reporting / Performance Portal
Incident Report for Trimble Transport & Logistics
Resolved
This incident has been resolved.
Posted Apr 18, 2018 - 15:54 CEST
Identified
We have identified degraded performance for reporting and Performance Portal. Investigation is ongoing.
Posted Apr 05, 2018 - 15:53 CEST
This incident affected: Fleetworks and Performance Portal.